Windows: Se você está preso em uma versão antiga do Internet Explorer no trabalho, mas tem privilégios suficientes para instalar um plug-in, o Google Chrome Frame acabou de sair do beta. O plug-in para IE processa as páginas usando a engine de renderização do Chrome em vez do IE – ou seja, você poderá usar páginas da web avançadas mesmo se for forçado a usar um navegador sem segurança e ultrapassado. O Google Chrome Frame Funciona no Internet Explorer 6, 7 e 8.

Por enquanto, o Chrome Frame requer provilégios administrativos para instalar o plug-in, o que pode ser um problema se você estiver em um confinamento severo de TI, mas isto pode não ser um problema no futuro. Do post do Google (destaque nosso):

Nós colocamos metas agressivas para lançamentos futuros: estamos trabalhando para tornar a inicialização ainda mais rápida e em remover o requisito atual de direitos administrativos para instalar o plug-in.

Promissor. [Google Chrome Frame via The Chromium Blog]